This project has moved and is read-only. For the latest updates, please go here.

Trouble setting up project "Can't find type for type name..."

Nov 19, 2015 at 9:51 PM
I'm having trouble determining the proper way to add references for my definition files.

I keep getting an error thrown in MessageContext.cs when it tries to do a GetType.
"Can't find type for type name = EdiFabric.Definitions.X12_004030_850.M_850,"

Now this is probably something simple, but as my first project using EDIFabric, I'm not able to figure out what I am doing wrong based on the the documentation on the site, or on the readme that came with the classes I purchased.

I've added the relevant CS files to the definition project and compiled it to a dll.
I've added a reference to the definitions project in the framework project and then compiled it.
I've tried adding both dll as references in my project.
I've tried adding the projects (framework/definitions) as references in my project.

I'm able to see the type (and do a type.gettype of it) in my own project.
But MessageContext.cs keeps failing.

What am I doing wrong here? Can someone who has done this before give me a pointer?
Nov 19, 2015 at 9:57 PM
And of course, 5 minutes later I figure it out.

I thought it was supposed to default to using "EdiFabric.Definitions" as the assembly to load from. It doesn't seem to actually do that.
When I changed:
Interchange.LoadFrom(IO.File.OpenRead(fi.FullName), "EdiFabric.Definitions")

it fixed the issue. But I believe it should use that as the default without my having to enter it.